TKGi - BOSH Error: Reserved IP 'x.x.x.x' is out of network '<NetworkName>' range
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TKGi - BOSH Error: Reserved IP 'x.x.x.x' is out of network '<NetworkName>' range

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Article ID: 387146

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Updated On:

Products

VMware Tanzu Kubernetes Grid Integrated Edition

Issue/Introduction

After running a Apply Changes on Bosh Director deployment you see below error via the UI.

Task XXXXX | 13:35:04 | Error: Reserved IP 'x.x.x.x' is out of network '<NetworkName>' range
...
Updating deployment:
  Expected task 'XXXXX' to succeed but state is 'error'

Exit code 1

When running a 'bosh task XXXXX --debug' command you see below error also:

D, [2025-01-01T13:35:04.241235 #39789] [task:XXXXX] DEBUG -- DirectorJobRunner: (0.000061s) (conn: 3820) BEGIN
D, [2025-01-01T13:35:04.241606 #39789] [task:XXXXX] DEBUG -- DirectorJobRunner: (0.000061s) (conn: 3820) UPDATE "task" SET "state" 'error', "timestamp" = '2025-01-01 13:35:04.250301+0000' , "description" = 'create deployment' , "result" = 'Reserved IP ' 'x.x.x.x' ' is out of network ' '<NetworkName>' range' , "output" = '/var/vcap/store/director/tasks/XXXXX', "checkpoint_time" = '2025-01-01 13:35:04.239955+0000', "type" = 'update_deployment' , "username" = 'ops_manager' , "deployment_name" = 'xxxxxxx', "started at" = '2025-01-01 13:35:04.239234+0000', "event_output" = '{"time":XXXXXXX, "error":{"code":XXXXXX,"message":"Reserved IP ' 'x.x.x.x' ' is out of network ' '<NetworkName>' range" }}', "result_output" = ' ', "context_id" = '' WHERE ("id" = XXXXX)
D, [2025-01-01T13:35:04.241739 #39789] [task:XXXXX] DEBUG -- DirectorJobRunner: (0.001001s) (conn: 3820) COMMIT
I, [2025-01-01T13:35:04.241893 #39789] [] INFO -- DirectorJobRunner: Task took 0.156009345 seconds to process.

Task XXXXX error

Capturing task 'XXXXX' output:
  Expected task 'XXXXX' to succeed but state is 'error'

Exit code 1

Environment

TKGi 1.18.5
BOSH 3.0.25+LTS-T

Cause

The Reserved IP settings in the Bosh Director tile - Network has an IP that is not usable due to it not being in the configured CIDR

IPs are reserved for VMs but since they are unresponsive Bosh cannot delete and reuse IPs or reclaim existing IPs.

Resolution

Update the Bosh tile in Network with the correct CIDR first of all, then update the Bosh cloud config with the correct static IP using below:

Store the current bosh cloud config with below command:

bosh cloud config > cloud.txt

Edit the cloud.txt file and update to add correct static IP:

...
static: [x.x.x.x]
...


Finally update the Bosh cloud config as per below command:

bosh update-cloud-config cloud.txt



Following this Apply Changes via the Bosh tile so the Bosh VM can recreate successfully.