Collecting Logs for troubleshooting HCX OSAM migration failures
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Collecting Logs for troubleshooting HCX OSAM migration failures

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Article ID: 386913

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Updated On:

Products

VMware HCX

Issue/Introduction

When a OSAM migration freezes or fails Broadcom Support will need logs uploaded to the case in order to troubleshoot the cause of the failure. 

Environment

  • VMware HCX
  • HCX OSAM

Cause

Troubleshooting is being performed and logs are required by Broadcom Support to investigate the concern further

Resolution

Collecting Linux sentinel logs

Linux Sentinel logs reside in /var/log/vmware/hcx/osam

  • Logon to the source system
  • Navigate to /var/log/vmware/hcx/
  • Tar the directory called osam using

    tar -czvf osam_logs.tar.gz osam/

Collecting Windows sentinel logs

  • Logon to the source system
  • Navigate to C:\ProgramData\VMware\HCX
  • Zip the directory called OSAM

Collecting OSAM Fixup logs

  • Logon to the source system
  • Navigate to C:\temp\
  • Zip the directory called Fixup

How to Collect Fixup Logs from a Target VM where the logs cannot be transferred out due to network/VMware tools issues

Steps

  1. Login to the Target vCenter.

  2. Access the Migrated VM

    • If powered on, log in using customer credentials.
    • If powered off, power on the VM first.
  3. Navigate to Fixup Logs Directory

    C:\temp\Fixup\fixup.log

    • Open fixup.log using Notepad.
    • Take a screenshot of the log file for analysis.
  4. If C:\temp\Fixup is Not Present

    C:\ProgramData\VMware\HCX\OSAM\sentinelService.log

    • Open sentinelService.log using Notepad.
    • Navigate to the end of the file and take a screenshot.

See the links below for detailed instructions on collecting HCX, vCenter and ESXi logs for Broadcom support

Technical Support Logs for the HCX Manager

Technical Support Logs for vCenter and ESXi

Additional Information

Direct Access to SDR Logs

  1. Login to the Target HCX Manager.

  2. Run ccli and Identify the SDR Appliance

    ccli list

  3. Access SDR Appliance

    go <sdr-id>

    ssh

  4. Navigate to Logs

Logs are located under /var/log/messages.

Direct Access to SGW Logs

  1. Login to the Source HCX Manager.

  2. Run ccli and Identify the SGW Appliance

    ccli list

  3. Access SGW Appliance

    go <sgw-id>

    ssh

  4. Navigate to Logs

Logs are located under /var/log/messages.