Registry is not able to start after DB password change, Oracle account is getting locked
search cancel

Registry is not able to start after DB password change, Oracle account is getting locked

book

Article ID: 386908

calendar_today

Updated On:

Products

Service Virtualization

Issue/Introduction

After changing the Oracle DB password and updating site.properties, the Oracle DB account is getting locked again and again.
There are multiple DevTest installations using the same Oracle DB account.

Environment

All supported DevTest versions using Oracle DB.

Cause

Any Oracle DB connection trying to use an old password will cause the Oracle DB account to be locked.

Resolution

  1. Stop all DevTest services on all installations.
  2. Unlock the Oracle DB account for the Registry database.
  3. Update the Oracle password in site.properties: Configure DevTest to Use Oracle
  4. Before starting the first Registry, confirm that the Oracle account is not getting locked caused by an unknown installation or process.
  5. Start one Registry at a time followed by the other services on each installation, confirming each time that the Oracle account is not getting locked.