DCS agent error-System Application Data Scan failed
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DCS agent error-System Application Data Scan failed

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Article ID: 386875

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Updated On:

Products

Data Center Security Server Advanced

Issue/Introduction

You see an error in the UMC events and need to know how to resolve it

SDCS Critical Error -- System Application Data Scan failed. Error: AppDataEngine::CollectAndSendData - Unable to get the ConfigXML document 

Environment

Data Center Security 6.9.x

Cause

The config.xml file was not accessible to run the automatic scan and a manual scan should be run to fix the error

Resolution

By default, DCS is configured to trigger an automatic Application Data Retrieval (ADR) scan as soon as an agent is registered with the manager

The setting can be turned off in the UMC to avoid this error when registering new agents 

The error can be fixed by initiating an application data retrieval command using the Discover Application feature of Unified Management Console

     1. Log on to Unified Management Console  and select Server from the dropdown

     2. Click Assets

     3. In the left navigation pane, click All Servers to display a list of all agents, or click a category to view the agents of that specific category
             (You can also use the search functionality to search for a specific asset)

     4.  Select the asset for which you want to discover application

     5. Click Discover Application


Once the scan is complete, another one will not run unless you follow the above steps

Note**ADR scan is not a required for the DCS agent functionality

For more info about the ADR scan, please review the following techdoc: 

About Application Data Retrieval