SRA command 'discoverDevices' failed. Failed to connect to the array management host. Please check EmcSrdfSra logs for more information on the error.
search cancel

SRA command 'discoverDevices' failed. Failed to connect to the array management host. Please check EmcSrdfSra logs for more information on the error.

book

Article ID: 386816

calendar_today

Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptom:

  • When you login to vCenter > SRM Plugin > Open Site Recovery > View Details > Site Pair >  Under Configure, select Array Pairs. We will see a warning suggesting SRA is unable to discover devices from storage array - " SRA command 'discoverDevices' failed. Failed to connect to the array management host. Please check EmcSrdfSra logs for more information on the error."

  • The SRM UI displays failed alert as below,

  • The Array pairs fails to ping each other,

Environment

Site Recovery Manager 8.x
Live Site Recovery 9.x

Cause

  • The error message provided indicates that the SRA (Storage Replication Adapter) command Discover Device failed because the address of the storage array is not reachable. The error could mean that the storage array Hostname is incorrect.

From /var/log/vmware/srm/vmware-dr.log found SRA command fails to discover devices

 2025-10-11T15:15:52.701+09:00 info vmware-dr[06791] [SRM@6876 sub=Storage opID=0adeed42-db7c-48c6-ae27-1137d259df77-discoverDevices:006f] DiscoveryComplete: Cross site discover devices completed
2025-10-11T15:15:52.701+09:00 error vmware-dr[06791] [SRM@6876 sub=Storage opID=0adeed42-db7c-48c6-ae27-1137d259df77-discoverDevices: 006f] Discovery complete: Failed to discover devices at local site:
(dr.storage. fault. CommandFailed) {
faultCause = (dr.storage.fault.LocalizableAdapterFault) {
faultCause = (vmodl.MethodFault) null,
faultMessage = <unset>,
code = "FD3D3A04-3DFB-4988-8B99-9A1292A2DD8B.1043",
arg = <unset>
msg = ""

faultMessage = <unset>,
commandName = "discoverDevices"
msg = ""

-> [context]zKq7AVECAAQAANjOcAELdm13YXJ1LWRyAAAsGRxsaWJ2bWFjb3JlLnNvAAF6WlxsaWJkci10eXBlcy5zbwABYudxApMUBmxpYmRyLXZtb21pLnNvAAP4VShsaWJkci1zdG9yYWd1
LnNvAANAyxQAzik0ANJCNADgfUkEsI4AbGlicHRocmVhZC5zby4wAAXf+g9saWJjLnNvLjYA[/context]
2025-10-11T15:15:52.702+09:00 verbose vmware-dr[06791] [SRM@6876 sub=PropertyProvider opID=Oadeed42-db7c-48c6-ae27-1137d259df77-discoverDevices: 006f
RecordOp REMOVE: taskInProgress ["dr.storage. ReplicatedArrayPair.discoverDevices25"], array-pair-11445. Applied change to temp map.
2025-10-11T15:15:52.702+09:00 info vmware-dr[06791] [SRM@6876 sub=DrTask opID=Oadeed42-db7c-48c6-ae27-1137d259df77-discoverDevices:006f] Task 'dr.storage. ReplicatedArrayPair.discoverDevices25' failed
-> (dr.storage. fault.CommandFailed)
faultCause = (dr.storage.fault.LocalizableAdapterFault) {
faultCause = (vmodl.MethodFault) null,
faultMessage = <unset>,
code = "FD3D3A04-3DFB-4988-8B99-9A1292A2DD8B.1043",
arg = <unset>
msg = ""

faultMessage = <unset>,
commandName = "discoverDevices"
msg = "

-> [ERROR]: [SYMAPI_C_SECURE_LIB_INIT_FAILURE : Secure client/server communications library (OpenSSL) could not be initialized. See the log file for detailed error

  • To address this issue, check the Storage Array and ensure that the storage array is up and running.  Ensure it's pingable from the SRM appliances.
    Verify the IP Address: Confirm that the IP address of the storage array is correct and reachable through the command line interface

Resolution

  • Open a new support ticket with Storage Vendor to investigate on, why the storage array cannot be reached by the SRA.

  • Everything pertaining to SRA-attached storage for the Site Recovery Manager Appliance is under the purview of the storage provider Therefore, it is necessary to isolate at storage vendor initially.

Additional Information

Update Dell SRA Solution Enabler to the most recent version of SRA or engage SRA vendor