Alert continues to trigger even though Alert Definition is deactivation in Policy of Aria Operations
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Alert continues to trigger even though Alert Definition is deactivation in Policy of Aria Operations

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Article ID: 386790

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

  • Alert Definition deactivated in Policy. However, these alerts continue to trigger on different objects.
  • Issue may not be limited to single alert but multiple alerts on different objects.

Environment

Aria Operations 8.x

Cause

Cache issue on Aria Operations causing Policy from being updated.

Resolution

As we do not have a fix available and the issue is under investigation.

Follow the below workarounds:

Option 1:

Place all the impacted objects in Maintenance for 1 minute, then remove object from maintenance.

  • Login to Aria Operations UI.
  • Go to Operations > Configurations > Inventory Management.
  • Search for the impacted object (VM, datastore, cluster etc) .
  • Click on the object, then click on "Start Maintenance" icon
  • Above is a screenshot where we have selected a cluster object.
  • Set Maintenance to end in 1 minute.

Once the maintenance is completed, ensure the object is in collecting state again.

You should now not see any alerts for alert definition that are deactivated in Aria Operations policy.

Option 2:

  • If the number of objects impacted are too many then take the Cluster offline and then bring it online using the admin page for Aria Operations. Follow this KB for the process of taking cluster offline and then bringing it online.

Additional Information