Alert Definition is deactivated in all policies. However, the alerts continue to trigger on different objects.
This issue may not be limited to a single alert, but multiple alerts on different objects.
Environment
Aria Operations 8.x
Cause
Cache issue on Aria Operations preventing the policy from being updated.
Resolution
As we do not have a fix available and the issue is under investigation, please follow the below workarounds:
Option 1:
Place all the impacted objects in Maintenance for 1 minute, then remove the object from Maintenance.
Login to Aria Operations UI.
Go to Operations > Configurations > Inventory Management.
Search for the impacted object (VM, datastore, cluster etc) .
Click on the object, then click on "Start Maintenance" icon
Above is a screenshot where we have selected a cluster object.
Set Maintenance to end in 1 minute.
Once the maintenance is completed, ensure the object is collecting again.
You should now not see any alerts for alert definitions that are deactivated in the Aria Operations policy.
Option 2:
If the number of objects impacted is too many, then take the Cluster offline and then bring it online using the admin page for Aria Operations. Follow this KB for the process of taking a cluster offline and then bringing it online.