"Failed to execute NsServiceGroup UUID check.. null" error during NSX manager upgrade pre-check
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"Failed to execute NsServiceGroup UUID check.. null" error during NSX manager upgrade pre-check

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Article ID: 386745

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Updated On:

Products

VMware NSX

Issue/Introduction

  • During the pre-check phase of an NSX upgrade, the following error is observed when checking the manager nodes: Failed to execute NsServiceGroup UUID check.. null
  • The checks in the Resolution section of Upgrade from 3.2.2 to 3.2.3 failing at Pre-upgrade check with NSSgroup UUID Check Null,

    grep "java.lang.NullPointerException,errorId=PROVIDER_INVOCATION_FAILURE" syslog | awk '{print $14}' | uniq | awk -F ':' '{print $2,$3}' | awk '{print $1,$2}'
    zgrep "java.lang.NullPointerException,errorId=PROVIDER_INVOCATION_FAILURE" syslog* | awk '{print $14}' | uniq | awk -F ':' '{print $2,$3}' | awk '{print $1,$2}'


    produce no results, indicating that there are no impacted service entries

Environment

VMware NSX-T Data Center
VMware NSX
Non-federated NSX installation

Cause

One or more objects were removed from the NSX inventory but stale database records referencing these deleted objects still exist.

Resolution

If you believe you have encountered this issue, please open a support case with Broadcom Support and refer to this KB article.

For more information, see Creating and managing Broadcom support cases.

Additional Information

When contacting Broadcom support, collect an NSX support bundle for all manager nodes and attach it to the case. Additionally, run the following commands from one of the NSX manger nodes (as the root user) and attach the resultant files to the case:

corfu_tool_runner.py -t Service -n nsx -o showTable > /image/Service.txt
corfu_tool_runner.py -t ServiceEntry -n nsx -o showTable > /image/ServiceEntry.txt
corfu_tool_runner.py -t InternalService -n nsx -o showTable > /image/InternalService.txt
corfu_tool_runner.py -t InternalServiceEntry -n nsx -o showTable > /image/InternalServiceEntry.txt
corfu_tool_runner.py -t GenericPolicyRealizedResource -n nsx -o showTable > /image/GenericPolicyRealizedResource.txt


It will likely be required for Broadcom support to reproduce the issue being experienced in your NSX installation. This will require a backup of one of the NSX Manager nodes to be taken while the issue is occurring. If possible, attach the backup file to your case. The backup passphrase used to take the backup will need to be provided to Broadcom support. See Backing Up and Restoring NSX Manager or Global Manager for more information on configuring NSX backups.