Enabling OAuth for RabbitMQ for Tanzu Application Service won't work for old Service instances
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Enabling OAuth for RabbitMQ for Tanzu Application Service won't work for old Service instances

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Article ID: 386714

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Updated On:

Products

VMware Tanzu Application Service

Issue/Introduction

Once followed the steps on the guide to activate Oauth for RabbitMQ: https://techdocs.broadcom.com/us/en/vmware-tanzu/data-solutions/tanzu-rabbitmq-on-cloud-foundry/2-4/tanzu-rabbitmq-cloud-foundry/enable-oauth-for-rabbitmq.html

You will notice that the service instances that are in the platform before activating Oauth won't be accessible and will fail to log into it.

Environment

RabbitMQ on any version after activating Oauth it won't be possible to log into old Service instances management UI.

Cause

This is done by the design of the service broker which communicate directly with TAS UAA, It has information about newly created service instances but not the old one's

Resolution

There isn't a workaround to make service instances active before OAuth was activated to work with UAA.

Customers should be aware that activating Oauth on a running environment will cause previous service instances to be inaccessible.