VMware vCenter Services report warning "vc.health.error.dbjob3" on VAMI
search cancel

VMware vCenter Services report warning "vc.health.error.dbjob3" on VAMI

book

Article ID: 386688

calendar_today

Updated On:

Products

VMware vCenter Server 8.0

Issue/Introduction

vc.health.error.dbjob3 warning appears in the vSphere Client or the Virtual Appliance Management Interface (VAMI).

 

Cause

The warning occurs when certain historical statistics data on the vCenter fail to roll up for over 72 hours. 

Resolution

Note - Take a snapshot of the vCenter Server. If the vCenter Server is a member of an Enhanced Linked Mode (ELM) replication setup, please keep in mind that you need to create offline snapshots (in powered off state) for all ELM nodes.

To address the issue, clear old tasks, events, and statistics data that are no longer relevant, following the steps outlined in the KB - Delete old tasks, events, and statistics data in vCenter Server 5.x, 6.x, 7.x, and 8.x.

 

Additional Information

In some cases, wait for about 48-72 hours for the next rollup job to be completed. This should automatically resolve the issue. 

You see a "vc.health.error.dbjob3" warning after a vCenter upgrade

Despite this warning, the overall health status of vCenter Server remains green. This issue does not impact vCenter Server operations but may affect historical statistics.