Cannot deploy Aria Operations management packs from Lifecycle Manager
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Cannot deploy Aria Operations management packs from Lifecycle Manager

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Article ID: 386639

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

Unable to deploy Aria Operations management packs using Lifecycle Manager using the following process:

  1. Log into LCM using Okta, select Marketplace
  2. Search for a management pack, e.g. Aria Operations Management Pack for Microsoft IIS
  3. Click Download, agree to EULA/Enter User Information
  4. Click Download

The request shows in the "Available" tab, then disappears, and the tab shows "You have not downloaded any marketplace content."

The request status for the download shows "Completed"

The logs at /var/log/vrslcm/vmware_vrlcm.log will show similar errors to this:

2025-01-24T16:34:10.239Z INFO vrlcm[1353] [pool-3-thread-42] [c.v.v.l.c.c.FileContentDatabase]  -- SOURCE LOCATION :: /data/marketplace/content/aria-operations-management-pack-for-microsoft-iis-2__version__9.0.0/aria-operations-management
-pack-for-microsoft-iis-2__version__9.0.0
2025-01-24T16:34:10.239Z INFO vrlcm[1353] [pool-3-thread-42] [c.v.v.l.c.c.FileContentDatabase]  -- content.getRepositoryIdentifier() :: marketplaceRepo
2025-01-24T16:34:10.239Z INFO vrlcm[1353] [pool-3-thread-42] [c.v.v.l.c.c.FileContentDatabase]  -- DESTINATION LOCATION :: marketplaceRepo
2025-01-24T16:34:10.240Z INFO vrlcm[1353] [pool-3-thread-42] [c.v.v.l.c.c.FileContentDatabase]  -- DESTINATION FOLDER LOCATION :: /data/vm-config/vmrepo/marketplaceRepo/3x/3xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx
2025-01-24T16:34:10.262Z INFO vrlcm[1353] [pool-3-thread-42] [c.v.v.l.c.c.ContentRepositoryController]  -- Content uploaded successfully in the content repo
2025-01-24T16:34:10.262Z INFO vrlcm[1353] [pool-3-thread-42] [c.v.v.l.u.f.FileUtil]  -- Directory is deleted : /data/marketplace/content/aria-operations-management-pack-for-microsoft-iis-2__version__9.0.0


2025-01-24T16:34:10.268Z INFO vrlcm[1353] [pool-3-thread-42] [c.v.v.l.p.c.m.t.CloudMarketplaceContentDownloadTask]  -- Updating downloaded product data to database.
2025-01-24T16:34:10.268Z INFO vrlcm[1353] [pool-3-thread-42] [c.v.v.l.m.s.MarketPlaceAppMetadataServiceImpl]  -- Save marketplace downloaded content.
2025-01-24T16:34:10.285Z WARN vrlcm[1353] [pool-3-thread-42] [o.h.e.j.s.SqlExceptionHelper]  -- SQL Error: 0, SQLState: 22001
2025-01-24T16:34:10.285Z ERROR vrlcm[1353] [pool-3-thread-42] [o.h.e.j.s.SqlExceptionHelper]  -- ERROR: value too long for type character varying(255)
2025-01-24T16:34:10.285Z ERROR vrlcm[1353] [pool-3-thread-42] [o.h.i.ExceptionMapperStandardImpl]  -- HHH000346: Error during managed flush [org.hibernate.exception.DataException: could not execute statement]
2025-01-24T16:34:10.286Z ERROR vrlcm[1353] [pool-3-thread-42] [c.v.v.l.m.c.IMarketPlaceAppMetadataControllerImpl]  -- Error while saving download entry:: {


2025-01-24T16:34:10.287Z ERROR vrlcm[1353] [pool-3-thread-42] [c.v.v.l.m.c.IMarketPlaceAppMetadataControllerImpl]  -- Unexpected exception occurred: org.springframework.dao.DataIntegrityViolationException: could not execute statement; SQL
 [n/a]; nested exception is org.hibernate.exception.DataException: could not execute statement
2025-01-24T16:34:10.287Z INFO vrlcm[1353] [pool-3-thread-42] [c.v.v.l.p.c.m.t.CloudMarketplaceContentDownloadTask]  -- Download successful.

Environment

VMware Aria Suite Lifecycle Manager 8.x
(vRSLCM) (LCM)

Cause

This issue is occurring due to a change in Marketplace where an attribute in the content has a value more than 256 characters

Resolution

This issue is fixed in version 9.0. 

To workaround the issue, you may download and install the content packs manually for the respective products from https://marketplace.cloud.vmware.com/


Additional Information

In cases where you may not have access to the marketplace outside of LCM, you may be able to find the downloaded content on the Appliance and then copy it off the appliance and manually install in the respective product.

To find the file directly after attempting to download it:

  1. SSH to LCM with the root account
  2. Browse to /data/vm-config/vmrepo/marketplaceRepo
  3. Run 'ls -lah' to determine the most recent timestamp in this directory. This should be the file you just attempted to download. 
         There will be directories here that are named for the first 2 characters of the UIDs that they represent.
         For example, if the content UID was named 3xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx it would be in a folder named 3x. The full path would be: /data/vm-config/vmrepo/marketplaceRepo/3x/3xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx    
  4. You can then move the 3xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx file off of the appliance using an SCP tool like WinSCP and rename it to the applicable file extension. In this case, it is a .pak file. 
  5. Install the content in the respective product manually


Note: If you are unsure about the folder/file name of the content you are attempting to install, you can search the logs for the download task and see the directory that LCM saved it to. 

Open the logs at /var/log/vrslcm/vmware_vrlcm.log and search for the Log messages related to the content you are installing in the example logs above you can see that the "DESTINATION FOLDER LOCATION" can be found before the SQL error.