Booting or restarting PhotonOS results in systemd-netword.service reproting as dead
book
Article ID: 386534
calendar_today
Updated On:
Products
VMware Aria Suite
Issue/Introduction
- When the appliances is restarted and rebooted, you cannot reach the website or SSH into it.
- When you access the appliance via console and execute 'systemctl status systemd-networkd', it return output similar to:
Network Service Down:
systemd-networkd.service - Network Service
Loaded: loaded (/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
Drop-In: /etc/systemd/system/systemd-networkd.service.d
└─override.conf
Active: inactive (dead)
Docs: man:systemd-networkd.service(8)
- Manually executing 'systemctl start systemd-networkd.service' successfully starts the service but on reboot it is dead again.
- Executing 'systemctl is-enabled systemd-networkd' shows the service is enabled.
- Executing 'ifconfig' or other IP check shows all proper networking is configured.
- Review of the vSphere environment shows proper network assigned and connected.
Environment
Aria Suite Lifecycle Manager 8.x
Aria Automation 8.x
Aria Operations 8.x
PhotonOS 3.x
Cause
This can occur when the symlink is missing from the required directory for service start to occur.
Resolution
Repair the symlink by executing:
systemctl enable systemd-networkd
This will create the symlink allowing you to reboot and the service should come up automatically.
Feedback
thumb_up
Yes
thumb_down
No