Resolving LCMVIDM74065 Error in Aria Suite Lifecycle for VMware Identity Manager (VIDM)
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Resolving LCMVIDM74065 Error in Aria Suite Lifecycle for VMware Identity Manager (VIDM)

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Article ID: 386526

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

The LCMVIDM74065 error occurs within Aria Suite Lifecycle when managing VMware Identity Manager (VIDM). This error can manifest during certificate replacement attempts or when powering on VIDM appliances.

Error: Error Code: LCMVIDM74065
Unable to update the node types in vIDM cluster. Refer to VMware Aria Suite Lifecycle logs for additional details.
com.vmware.vrealize.lcm.vidm.common.exception.VidmClusterMasterNotFoundException: Choose one of the node to be considered as a master - .
    at com.vmware.vrealize.lcm.vidm.core.task.VidmClusterUpdateNodeTypesTask.retry(VidmClusterUpdateNodeTypesTask.java:311)
    at com.vmware.vrealize.lcm.automata.core.TaskThread.run(TaskThread.java:60)
    at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)
    at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
    at java.base/java.lang.Thread.run(Unknown Source)

Environment

VMware Identity Manager 3.3.7

Aria Suite Lifecycle 8.18

Cause

  1. Certificate Replacement Issue:
    • The certificate replacement fails because the VMware Identity Manager certificate has already expired and the Load Balancer certificate has not been updated.
  2. Power-On Task Failure:
    • The issue occurs when any of the VMware Identity Manager appliances enters quarantine mode, which can happen as a result of a network outage.

Resolution

  1. For Certificate Replacement Issue:
  • Step 1: Update the load balancer certificate.
  • Step 2: After updating the Load Balancer certificate, attempt to replace the VMware Identity Manager certificate from Aria Suite Lifecycle (LCM).
  • This should resolve the certificate replacement issue, allowing the process to complete successfully.
  1. For Power-On Task Failure:
  • Step 1: Resolve the Quarantine issue affecting the VMware Identity Manager appliance by following the instruction in the KB Pgpool commands that are not working in one node of VIDM
  • Step 2: Once the quarantine issue is resolved, retry the power-on task for VMware Identity Manager from Aria Suite Lifecycle (LCM).