Cannot create or modify Agent Group - UI Error: "Failed to Save Configuration"
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Cannot create or modify Agent Group - UI Error: "Failed to Save Configuration"

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Article ID: 386464

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

When try to Edit/Modify/Delete an existing Agent Group, or when try to create a new Agent group, UI responded with "Failed to Save Configuration". In addition, the following behaviors were observed:

  • UI failed to load.  UI comes back after a few minutes.
  • Loginsight service was reloaded.

Environment

Aria Operations for Logs 8.x

Cause

One or more Agent Group is configured with excessive number of hosts.  This lead to loginsight service crash due to buffer overflow when trying to edit any existing or create a new Agent Group.  The following error can be seen from the logs events:

In ui_runtime.log:

[2025-01-16 16:55:37.095+0000] ["https-openssl-apr-443-exec-10"/192.168.68.248 INFO] [com.vmware.loginsight.web.config.UIConfigManager] [UIConfigManager received setConfigRequest]
[2025-01-16 16:55:37.140+0000] ["https-openssl-apr-443-exec-10"/192.168.68.248 WARN] [com.vmware.loginsight.web.config.UIConfigManager] [UIConfigManager setConfigRequest unsuccessful, reason: Socket is closed by peer.]
[2025-01-16 16:55:37.142+0000] ["https-openssl-apr-443-exec-10"/192.168.68.248 ERROR] [com.vmware.loginsight.web.actions.settings.AgentsActionBean] [Failed to save agent configuration]
com.vmware.loginsight.config.ConfigurationException: Socket is closed by peer.
        at com.vmware.loginsight.web.actions.settings.AgentsActionBean.saveNewConfig(AgentsActionBean.java:739) ~[classes/:?]
        at com.vmware.loginsight.web.actions.settings.AgentsActionBean.applyAgentsConfig(AgentsActionBean.java:696) [classes/:?]
        at jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[?:?]
        at jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[?:?]

In runtime.log, on the same time period when the above logging occurred:

[2025-01-16 16:56:24.473+0000] [main/192.168.68.248 ERROR] [com.vmware.vipclient.i18n.messages.api.opt.local.LocalMessagesOpt] [Failed to get offline messages for product: JavaclientTest 1.0.0, component: JAVA, locale: en, exception: Failed to get resource
bundle for locale: en]
[2025-01-16 16:56:24.546+0000] [main/192.168.68.248 ERROR] [com.vmware.loginsight.config.CollectionAgentsConfig] [Error parsing criteria for class BCCR_ADFS. Ignoring class.]
com.vmware.loginsight.commons.expr.ParseError: Stack overflow while parsing expression

In the above logs, in this example, the "BCCR_ADFS" agent group was configured with too many hosts, causing a buffer overflow, which reset the loginsight service.

 

Resolution

To fix this Agent Group issue, delete the existing problematic Agent Group.

Method 1:  If Delete Option is available via UI.

  • Login to Aria Operations for Logs UI.
  • Under Management > Agents, Select the problematic Agent Group, click on X to delete.

Method 2:  If Delete Option failed via UI, remove the problematic Agent Group from Internal Configuration.

  • Login to Aria Operations for Logs UI.
  • Open a new tab, go to https://<Aria_Operations_for_logs_FQDN>/internal/config
  • Search for the problematic Agent group.  The Group should consist of a beginning section to the end section as followed:
    • Using the above example:  The problematic group is "BCCR_ADFS"
    • The line start from and ends with
      • <class name="BCCR_ADFS" namespace="">
      • </class>
  • Once the above parameters have been deleted, click "Save" to save the configuration.

Once the problematic Agent Group has been deleted, the existing Agent Group can be edited, and new Agent Group can be created. The loginsight service will no longer be crashing.