Unable to add ESXi host to the vCenter after changing the management IP of the host
search cancel

Unable to add ESXi host to the vCenter after changing the management IP of the host

book

Article ID: 386415

calendar_today

Updated On:

Products

VMware vCenter Server 7.0 VMware vCenter Server 8.0

Issue/Introduction

ESXi is in "Disconnected" state on vCenter.

When attempting to add the ESXi host to vCenter, error message is "Unable to access the specified host, either it doesn't exist, the server software is not responding, or there is a network problem"

Environment

vCenter 8.x

Cause

  • vCenter is unable to resolve the FQDN of the ESXi host's new IP, due to a stale DNS entry.
  • Pinging the FQDN returns an outdated or incorrect IP address.
  • The old DNS information is cached within vCenter, preventing it from reflecting recent DNS changes.

Resolution

  • Update the correct host records (A Record and PTR records) in the DNS server.
  • Verify the same from the jump server/local machine (nslookup FQDN / IP).
  • Flush the DNS entries from the vCenter by restarting the DNS service.

         systemctl restart dnsmasq.service