Data Services Manager LDAP authentication is not working
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Data Services Manager LDAP authentication is not working

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Article ID: 386319

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Updated On:

Products

VMware Data Services Manager

Issue/Introduction

In rare situations Data Services Manager LDAP login does not complete on version 2.2

Symptoms:

Currently no message or alert will appear for this in the GUI.

In the log provider/provider.log you may see the following message:

 Caused by: javax.naming.NamingException: LDAP response read timed out, timeout used: 10000 ms.

Environment

VMware Data services Manager 2.2

Cause

DSM Version 2.2 introduced an Authentication Timeout which is set to 10 seconds by default.

This can lead to LDAP queries timing out during retrieval of user's ancestor groups. 

Large Active Directories may require more time and in these situations user may need to increase the timeout duration manually.

 

 

Resolution

Steps to increase the timeout duration 

 

SSH to Provider VM

ssh root@DSM-provider

 

Edit YAML file located at:


vi /opt/vmware/tdm-provider/providerservice/config/application.yml

Add following line under the "spring" section of the yml file:

ldap.read.timeout.milliseconds: 20000


Example:


Save the file and restart the provider.service by executing following command:

     systemctl restart provider.service

Wait a minute and try to login with a AD User