NSX upgrade bundle fails to upload because of insufficient disk space
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NSX upgrade bundle fails to upload because of insufficient disk space

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Article ID: 386261

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Updated On:

Products

VMware NSX VMware NSX-T Data Center

Issue/Introduction

While uploading the upgrade bundle mub file, an error shows insufficient disk space in NSX Manager appliance:

Not enough space on disk /image/upgrade-coordinator-tomcat/temp to download upgrade bundle. Minimum space required should be twice of the Main Upgrade Bundle(.mub) file size. Available Space: #### MB. Required Space #### MB.

Environment

VMware NSX 4.x
VMware NSX-T Data Center 3.x

Cause

Insufficient disk space in manager appliance.

Resolution

Run this command to check the available space on the /image partition:

  • From admin CLI: get filesystem-stats | find 'Avail|/image'
  • From root shell: df -h /image/

Check for files under /image partition:

  • In the NSX Manager CLI, delete the unused files located at /image/vmware/nsx/file-store/ and /image/core/
    Back up any file locally that may be required in future.
    Note: Do not delete any file if unsure about the file content. Please contact Broadcom support.
    Ensure to not delete the /image/upgrade-coordinator-tomcat folder or other folders located at /image.
  • From a browser, log in to each of the three NSX Manager nodes individually using their IP address or FQDN. Navigate to System > Support Bundle, and remove any old or unnecessary support bundles.
    Download support bundle locally if required for review in future.
  • Delete any old packet capture (pcap) files.
    Download the file locally before deleting if required for review in future.

Once the necessary free space is reclaimed, re-upload the upgrade bundle and continue with the upgrade process.

Additional Information