Error: "The entity Ref: com.vmware.vcloud.entity.vimserver:#### is busy completing an operation SYSTEM_UPDATE_VIMSERVER. SYSTEM_UPDATE_VIMSERVER" when reconnecting vCenter to VMware Cloud Director
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Error: "The entity Ref: com.vmware.vcloud.entity.vimserver:#### is busy completing an operation SYSTEM_UPDATE_VIMSERVER. SYSTEM_UPDATE_VIMSERVER" when reconnecting vCenter to VMware Cloud Director

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Article ID: 386247

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • vCenter Server (VC) status on VMware Cloud Director (VCD) Provider portal shows as "Busy".
  • The VC reconnect on VCD provider portal fails with the error below:

    [ ####-#######-####-########8d22 ] The entity Ref: com.vmware.vcloud.entity.vimserver:####-#######-####-########c979 is busy completing an operation SYSTEM_UPDATE_VIMSERVER. SYSTEM_UPDATE_VIMSERVER(com.vmware.vcloud.entity.task:####-#######-####-########2d29)

  • In /opt/vmware/vcloud-director/logs/vcloud-container-debug.log you see the error reported below:

    DATE TIME | ERROR    | pool-jetty-241579         | JDBCExceptionReporter          | Batch entry 0 /* Method: unknown */ /* Method: unknown */ /* insert com.vmware.vcloud.common.model.BusyObjectModel */ insert into busy_object (shared_count, task_id, object_id, object_type) values (0, '####-#######-####-########9820'::uuid, '####-#######-####-########c979'::uuid, 4) was aborted: ERROR: duplicate key value violates unique constraint "busy_object_pk"  Detail: Key (object_type, object_id)=(4, ####-#######-####-########c979) already exists.  Call getNextException to see other errors in the batch. | requestId=####-#######-####-########a0ac,request=POST https://cloud.example.com/api/admin/extension/vimServer/####-#######-####-########c979/action/fo...,requestTime=1737385781506,remoteAddress=##.##.##.##:13158,userAgent=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 ...,accept=application/*+json;version 40.0.0-alpha

Environment

VMware Cloud Director 10.6

Cause

There is already a running task for VC causing the failure of the VC reconnect task.

 

Resolution

The workaround for this issue requires modification of the Cloud Director database.

To resolve this issue, contact Broadcom Support and note this Article ID (386247) in the problem description. For more information, see Creating and managing Broadcom support cases.