After upgrade to ESXi 8.0 U1/U2, vsanmgmt stops logging in a vSAN cluster.
search cancel

After upgrade to ESXi 8.0 U1/U2, vsanmgmt stops logging in a vSAN cluster.

book

Article ID: 386238

calendar_today

Updated On:

Products

VMware vSAN 8.x

Issue/Introduction

Symptoms:

  • vsanmgmt fails to print logs after upgrade of vSAN hosts to 8.x versions prior to 8.0 U1/U2.

  • Latest logging in this log file is of connection to hostd being down though hostd service is healthy and running.

    (in /var/run/log/vsanmgmtd.log):

    2024-08-24T14:46:38.870Z warning vsand[#######] [opID=Thread-7 VsanTaskTrackerImpl::_ThreadMain] Connection to hostd is down, need to reconnect

Environment

  • VMware vSAN 8.0 U1

  • VMware vSAN 8.0 U2

Cause

  • Its a known issue with ESXi 8 U1 and U2 where on upgrade to these versions, the vsanperf.conf file fails to update syslog indent from VSANMGMTSVC to vsand.

Resolution

  • Upgrade vSAN hosts to 8.0 U3 or later.

  • Workaround:

      1. On all hosts, need to change "syslogident = VSANMGMTSVC" to "syslogident = vsand" in /etc/vmware/vsan/vsanperf.conf

      2. Restart vsanmgmt service run the following command:
        # /etc/init.d/vsanmgmtd restart