After upgrade to ESXi 8.0 U1/U2, vsanmgmt stops logging in a vSAN cluster.
search cancel

After upgrade to ESXi 8.0 U1/U2, vsanmgmt stops logging in a vSAN cluster.

book

Article ID: 386238

calendar_today

Updated On:

Products

VMware vSAN 8.x

Issue/Introduction

This does not cause any functional issue in vSAN but may impact troubleshooting other issues that rely on vsanmgmt logging. 

Environment

VMware vSAN 8.0.x

Cause

The vsanperf.conf file on the hosts have been modified after the upgrade whereby under #syslog identification the value is set to "syslogident = VSANMGMTSVC"

Resolution

Upgrade the environment to 8.0 U3 or later.

 

If an upgrade is not possible at this time, the following workaround can be implemented:

On all hosts, need to change "syslogident = VSANMGMTSVC" to "syslogident = vsand" in /etc/vmware/vsan/vsanperf.conf and restart vsanmgmt service.

To restart vsanmgmt service run the following command: /etc/init.d/vsanmgmtd restart