ESXi 8.0U3 frequently reports "Cannot login user root@127.0.0.1: no permission" when lockdown is enabled
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ESXi 8.0U3 frequently reports "Cannot login user [email protected]: no permission" when lockdown is enabled

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Article ID: 386226

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

The "Events" tab of a 8.0u3 ESXi host is being spammed with the following message:
"Cannot login user [email protected]: no permission"

Environment

ESXi 8.0U3 

Cause

The vsan_health plugin is launched every 5 minutes to capture the vSANmgmt daemon health. The plugin tries to log in to hostd service as "root". When the host is in lockdown mode, the "root" user will be disabled. Hence the error log is expected in hostd.log.

Resolution

The fix for this will be released in ESXi 8.0u3 P05. Otherwise, you can apply the following workaround to affected hosts;

Disable the vsan_health plugin on the host, via this command:
# configstorecli config current set -c esx -g health -k vsan_health --path "enabled" --value False

Restart the healthd via this command:
# /etc/init.d/health restart