NCM is not detecting the differences in device families in Spectrum
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NCM is not detecting the differences in device families in Spectrum

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Article ID: 386132

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Updated On:

Products

Spectrum

Issue/Introduction

We have created several custom device families, but we have noticed that even obvious changes are not being detected.  What can cause this type of behavior?

Environment

Spectrum  Any

Network Configuration Manager (NCM)

Cause

The default comparison mask has been removed from the custom device family.

Resolution

When you create a custom NCM device family, by default we include the comparison mask of [!#] and this is required for NCM to function and detect changes.

A blank or empty comparison mask will not allow proper difference comparisons.

Additional Information

If you want to detect changes with the hash # character then the bare minimum of comparison mask is [!],  if this is not used then NCM will only detect changes in the very first line which is the date and time.