Avi Service Engine Group license with incorrect license tier caused controller fault "Controller over Service Unit Limit"
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Avi Service Engine Group license with incorrect license tier caused controller fault "Controller over Service Unit Limit"

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Article ID: 386075

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Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

The controller will display the error/fault below although the license status is UP (green) and your license units usage is not over the limit.

"Controller over Service Unit Limit, go to VMware Cloud Services Portal or contact VMware Support".

In CLI with command "show license ledger details" you will see the Enterprise License usage with a negative value for "remaining."

[admin:example]: > show license ledger details
+-----------------+-----------------------------------------+
| Field           | Value                                   |
+-----------------+-----------------------------------------+
| uuid            | default                                 |
| tier_usages[1]  |                                         |
|   tier          | ENTERPRISE                              |
|   usage         |                                         |
|     available   | 0.0                                     |
|     consumed    | 6.0                                     |
|     escrow      | 0.0                                     |
|     remaining   | -6.0                                    |

In the same command output you will find Service Engines deployed in the incorrect license tier, which will match the negative value of "remaining."

|  se_infos[4]     |                                         |
|   uuid          | se-UUID                         |
|   tenant_uuid   | admin                                   |
|   tier          | ENTERPRISE                              |
|   service_cores | 3.0                                     |
|   last_updated  | 0                                       |
--SNIP--
|  se_infos[13]    |                                         |
|   uuid          | se-UUID                         |
|   tenant_uuid   | admin                                   |
|   tier          | ENTERPRISE                              |
|   service_cores | 3.0                                     |
|   last_updated  | 0                                       |

When checking the Service Engine Group of the Service Engines with the incorrect license tier, you will find the SE Group is set with the incorrect license tier.

[admin:example]: > show serviceenginegroup example | grep license_tier
| license_tier                                  | ENTERPRISE                                              |

 




 

Environment

Affects Version(s):

22.1.4

Cause

This is a known issue when converting/changing the controller's license tier from Enterprise to Enterprise with Cloud Services.

Resolution

This issue has been resolved in the latest 22.1.x or 30.x versions.

Workaround(s):

Steps:

  1. ssh to the controller leader node with the admin user and launch the CLI by entering "shell" and login with admin
  2. Change the license tier of the affected SE Group

    configure serviceenginegroup SE_GROUP_NAME
    license_tier enterprise_with_cloud_service
    save

  3. Reboot the existing Service Engines OR delete and redeploy new Service Engines.

Refresh the license count with the following API endpoint if the usage count under Administration > Licensing does not auto update.

http://CONTROLLER_IP_FQDN/apilicensing/saas/reconcile