Error Code: MONS-025 when opening sqlserver probe from Admin Console
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Error Code: MONS-025 when opening sqlserver probe from Admin Console

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Article ID: 386070

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM) CA Unified Infrastructure Management On-Premise (Nimsoft / UIM) CA Unified Infrastructure Management SaaS (Nimsoft / UIM)

Issue/Introduction

I'm using Admin Console to configure the sqlserver probe installed on secondary hub to monitor sql server database for five remote sql servers.

After I defined the sqlserver connections, I start to define the profile. After a couple of profiles I get the following pop-up error on save the sqlserver probe configuration:

Message: The probe provisiong service at probe address reported a failure 
Resolution: review the PPM probe logs
Error Code: MONS-025

After I get this error I'm no longer able to open the SQLServer probe.

I tried to investigate corruption via Notepad++ but I was unable to found bad entry/characters/profile in the sqlserver_monitor.cfg  configuration file.

Environment

  • UIM 23.4.0
  • ppm 23.4.0
  • sqlserver probe 5.61

Cause

These empty sections comprised the dupes like shown above so searched on:

</connection_memory>
</0>
</lock_memory>
</optimizer_memory>
</sqlcache_memory>
</total_memory>

...and then I deleted those two lines for each dupe to repai the cfg file - what you see highlighted below in yellow.

Resolution

  1. Deactivate the sqlserver probe.

  2. Rt-click and delete it

  3. Delete the sqlserver folder from the file system

  4. Download the sqlserver_monitor.cfg_repaired file and change the name to sqlserver_monitor.cfg.

  5. Install the ade probe on the secondary hub

  6. Then remove ppm completely and deploy ppm 23.4.2

  7. Then remove the sqlserver '-T2' version completely and redeploy just the sqlserver 5.61 (GA).

  8. Replace the default sqlserver_monitor.cfg with the repaired version I provided.

  9. The original sqlserver_monitor.cfg had some duplicated section tags which needed to be removed.

  10. Clear cache in your browser (all time/everything)

  11. Restart primary hub.

  12. Test again by opening the sqlserver configuration in the Admin Console and all of the previously defined connections seen in IM should be displayed in the AC.

Warning: Please avoid switching between using the IM and using the Admin Console to change the configuration, if that was being done, as it may cause unexpected results/cfg file corruption. This applies to all probes. Use either Admin Console if its supported for the given probe, or the IM but not both. That seemed to be the case here.