Load DWH fails with error "Could not login to Jaspersoft"
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Load DWH fails with error "Could not login to Jaspersoft"

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Article ID: 38606

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

The Load Data Warehouse (DWH) job fails with error: Could not login to Jaspersoft, domains could not get updated for customizations.

 

Environment

Release: All Supported Releases
Component: Clarity Data Warehouse

Cause

The possible causes:

1. Jaspersoft server is not running.
2. Generic domain issue.
3. Out of box user with username ppmjasperadmin has been modified and hence Jaspersoft is not able to authenticate the Clarity report user ppmjasperadmin

 

Resolution

  • Make sure Jaspersoft server is up and running.

    Run the 'Restore Domains' job

    If this job fails also, please refer to Clarity PPM Restore Domains Job Failed

  • Check for the username ppmjasperadmin by running the below query and it should return one record  
    • SELECT * FROM cmn_sec_users
      WHERE user_name = 'ppmjasperadmin'
  • If the above query doesn't return a row which means username has been modified, then run another query to find out 
    • SELECT * FROM cmn_sec_users
      WHERE user_uid = 'ppmjasperadmin'
  • Update the username for resourceid - ppmjasperadmin via Clarity --> Administration --> Resources --> search for resourceid = ppmjasperadmin and update the username to ppmjasperadmin

Note: Please do not make any changes to any out of box seeded users 

Additional Information

See also: Load DWH job frequently reported issues

Attachments

1558686654172000038606_sktwi1f5rjvs16f0y.jpeg get_app
1558686651067000038606_sktwi1f5rjvs16f0x.jpeg get_app