Site Server is not completely downloading DriverDB Package. HTTP 500 and block is invalid for file is observed.
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Site Server is not completely downloading DriverDB Package. HTTP 500 and block is invalid for file is observed.

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Article ID: 386059

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Updated On:

Products

Client Management Suite Deployment Solution IT Management Suite

Issue/Introduction

This issue may present itself in a few different ways.  In this particular case, it was observed that the DriverDB package on the site server was not completing its download.  The following was noticed when downloading:

When it tries to connect to download it gets an IIS error:  HTTP status 500: An unexpected condition prevented the server from fulfilling the request (0x8FA101F4)

Block 0 (32697/36709) is invalid for file '\Program Files\Altiris\Altiris Agent\Package Delivery\{20827DDD-C698-49E8-B312-830DF1D935B2}\cache

Environment

Deployment Solution 8.x

Cause

Unexpected file on SMP in C:\Program Files\Altiris\Deployment\DriversDB.  In this particular it was found that inside the driver folder, was a web.config file.  

How this file was added is not known at this time.  If using the SMP console, Driver Database Management UI, this behavior is not something that can be reproduced.  For example, when using the Driver Database Management UI to add drivers, the drivers are added from the vendor in a .ZIP format.  The Driver Database Management UI will then extract these files and put them into the folder C:\Program Files\Altiris\Deployment\DriversDB\NameOfDriver.  Even if that ZIP archive has a web.config file in it, it will not be included in the directory.

Resolution

The resolution in this particular case would be to delete all instances of the web.config file from the SMP server and or Site Servers.  

If you do experience this issue there is one other item that you should check.  That is the applicationhost.config file on the SMP and site servers.  Located by default under C:\Windows\System32\inetsrv\Config you should make a copy of this file and then open the copy.

With the copy of the file opened, you will want to search for the section titled <location path="Default Web Site/Altiris/ClientTaskServer">

That section should look like the following:

<providers>
                            <clear />
                            <add value="Negotiate" />
                            <add value="NTLM" />
                        </providers>

If you have duplicate entries, this is a problem.  If you are using the 8.7.2 release of the product you will want to apply the cumulative point fix located here: CUMULATIVE POST ITMS 8.7.2 POINT FIXES  Download file: "SMA_SMP_8_7_2_PF_v8_15Jan2025.zip" or newer.