Unable to delete Switch IPFIX Profile from NSX UI.
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Article ID: 386008
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Updated On:
Products
VMware NSX
Issue/Introduction
A segment is configured as a source for a Switch IPFIX profile.
The profile and its associated segments are no longer deleted, so the necessary IPFIX profile must be deleted.
While deleting it, the following error is reported:
" Cannot delete profile <IPFIX-Switch-Profile> as it has 1 association(s) in 'Applied To' field. Please remove all the association(s) and try again. "
Switch IPFIX Profile:
The 'Applied To' do not report any Segment/Segment Port/Group connected in NSX UI.
Due to this, the IPFIX profile cannot be deleted until and unless the assigned port/segment/group is removed from the profile.
Environment
VMware NSX 4.x VMware NSX Data Center 3.x
Cause
The segment was deleted before the IPFIX profile was removed, causing a stale entry for the required profile. As a result, NSX continues to show an entry associated with the profile.
Resolution
It is not recommended to delete a segment that is being used as a source for an monitoring, before removing it from the configured Switch IPFIX profile.
This would prevent any stale entries from being created for the profile that might cause issues later.
Once the segment has been removed from the IPFIX profile it was associated with, it can then be removed as per the requirement.
If a segment has been deleted before removing from the Switch profile, please reach out to Broadcom Support team for assistance.