Issue
When trying to update or create a record within CA Service Desk Manager (CA SDM), "AHD04116: A duplicate record was encountered. Insert or Update failed" error is received.
Environment
CA Service Desk Manager 12.9 and 14.1
Windows, Unix and Linux
Cause
CA SDM caches IDs and CA SDM migrations/upgrades might cause them to go out of sync with what resides in the MDB database, which may then return the AHD04116 error message
Resolution
If a CA SDM migration/upgrade had been recently performed, run the following command from the CA SDM server:
pdm_key_refresh -y
If the issue still persists, please contact CA Support to open a support ticket.