AHD05072 error when accessing to Service Point notification
search cancel

AHD05072 error when accessing to Service Point notification

book

Article ID: 385879

calendar_today

Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

The following error appears when clicking on a Service Point notification, in the incidentMS.log (located in the xFlow install APPS/logs folder)

[bui.controllers.MyTicketsController] - Failed to fetch the cr object for API getMyTicketDetails.
[c.c.c.a.SdmGetObjectByPersidActor] - Error doing dob_by_persid (cr:411654): Error : AHD05072:La configuración de seguridad impide la consulta de este registro
[c.ca.casm.framework.util.CasmFuture] - Exception occurred, see call stack for more details: userid (the-userid)
java.util.concurrent.CompletionException: com.ca.casm.exception.CasmBaseException: Error : AHD05072:La configuración de seguridad impide la consulta de este registro
 at java.base/java.util.concurrent.CompletableFuture.encodeThrowable(CompletableFuture.java:331)
 at java.base/java.util.concurrent.CompletableFuture.completeThrowable(CompletableFuture.java:346)
 at java.base/java.util.concurrent.CompletableFuture.uniWhenComplete(CompletableFuture.java:870)
 at java.base/java.util.concurrent.CompletableFuture$UniWhenComplete.tryFire(CompletableFuture.java:837)
 at java.base/java.util.concurrent.CompletableFuture.postComplete(CompletableFuture.java:506)
Caused by: com.ca.casm.exception.CasmBaseException: Error : AHD05072:La configuración de seguridad impide la consulta de este registro
 at com.ca.casm.actor.SdmGetObjectByPersidActor.recvmsg1(SdmGetObjectByPersidActor.java:197)
 at com.ca.casm.actor.MdcActor$1.apply(MdcActor.java:213)
 at akka.actor.ActorCell$$anonfun$become$1.applyOrElse(ActorCell.scala:606)
 at akka.actor.Actor.aroundReceive(Actor.scala:517)
 at akka.actor.Actor.aroundReceive$(Actor.scala:515)

Above entry in bold reads as "Security settings prevent this record from being viewed"

Environment

Release : 17.3 or higher

Component : SDM - Service Point

Cause

Data Partition being used by the user in Service Point has a restriction to call_req

Resolution

1. Review the Data Partition(DP) being used by the contact. 

There are 2 ways to assign a DP: 

  • a. Role: Identify the role being used by the contact in Service Point: Administration > Security and Role Management > Contacts > Search and click on contact > See the Access Type > Go to Security and Role Management > Access Types > Click on the Access Type > 4. Apps tab > Click on "Service Point" > Click on the role and check the Data Partition assigned
  • b. Contact: Identify the DP assigned to the contact: Administration > Security and Role Management > Contacts > Click on Contact and check the Data Partition assigned.

2. Review the Data Partition and edit/remove the restriction to View call_req