vApp/VM power on tasks stuck in VMware Cloud Director after replacing SSL certificates on vCenter server
book
Article ID: 385804
calendar_today
Updated On:
Products
VMware Cloud Director
Issue/Introduction
SSL certificates were replaced on vCenter and it's connection was validated in VCD to trust new certificates
vApp/VM power on task gets stuck in VMware Cloud Director (VCD) and does not reach vCenter Server
In /opt/vmware/vcloud-director/logs/networking.log and vcloud-container-debug.log on VCD cell, 'Waiting for segment' events are reported for multiple networks
DEBUG | Backend-activity-pool-111 | OverlaySegment | Waiting for segment Network name (xxxxx-xxxx-xxxx-xxxx-xxx xxxxxxx) with logicalSwitchId switch-uuid to show up in vCenter | requestId=xxxxxx-xxxxx-xxxxx-xxxxx-xxxxxxxxx,request=POST https://VCD_URL/api/vApp/vapp-xxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxx/action/deploy,requestTime=1736840861799,remoteAddress=IP_address:port_number,userAgent=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 ...,accept=application/*+xml;version 40.0.0-alpha vcd=xxxxx-xxxxx-xxxx-xxx-xxxxxxxxx,task=xxxxxx-xxxxx-xxxxx-xxxxx-xxxxxxxxx activity=(com.vmware.vcloud.backendbase.management.system.TaskActivity,urn:uuid:xxxxxx-xxxxx-xxxxx-xxxxx-xxxxxxxxx) activity=(com.vmware.ssdc.backend.services.impl.DeployVAppActivity,urn:uuid:xxxxxx-xxxxx-xxxxx-xxxxx-xxxxxxxxx) activity=(com.vmware.ssdc.backend.DeployVAppVmSubsetActivity,urn:uuid:xxxxxx-xxxxx-xxxxx-xxxxx-xxxxxxxxx)
vCenter connection status is reported as down in NSX UI
Environment
VMware Cloud Director 10.x VMware NSX
Cause
This issue occurs following the replacement of SSL certificates on vCenter server and as a reason VMware Cloud Director (VCD) and NSX encounter a disruption, resulting in the inability to manage network-related tasks