NSX EDGE Transport Nodes show "Not Available" for both "Tunnel" and "Node Status"
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NSX EDGE Transport Nodes show "Not Available" for both "Tunnel" and "Node Status"

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Article ID: 385787

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Updated On:

Products

VMware NSX

Issue/Introduction

In NSX-T 3.2.2.1 there is a condition within the NSX Manager which will cause the "search indexing" mechanism to report "Unknown" for certain Transport Nodes when queried. 

Verified Transport Zone profile exists by searching TZ UUID in NSX GUI elastic search tool. 

 

 

 

Environment

NSX-T.3.2.2

Cause

This symptom can be caused by a stale Transport Zone issue OR an issue with the "search indexing" mechanisms. 

Resolution

Verify the attached transport-zone for the affected node is searchable using the elastic search tool via NSX GUI. You may also use the below API call:

GET /api/v1/transportzone-profiles?include_system_owned=true

If the TZ is not shown or is not searchable in the NSX elastic search tool please follow KB: 

NSX Host or Edge Transport Nodes have a status of "Unknown" and Tunnels are "Not Available" or "Validation Errors"

 

Workaround:

If there are no issues with the TZ please edit the Transport Node via NSX GUI and click "save" . 

This is resolved in NSX 3.2.3.1

 

 

Additional Information

If the above workaround does not work for you, please collect the below information and open a support request with Broadcom. 

  • NSX Edge and Manager bundles
  • Output for the following API calls:
    GET /api/v1/transportzone-profiles?include_system_owned=true
    GET /api/v1/transport-nodes/
    GET /api/v1/transport-nodes/<tn-uuid>