NSX EDGE Transport Nodes show "Not Available" for both "Tunnel" and "Node Status".
search cancel

NSX EDGE Transport Nodes show "Not Available" for both "Tunnel" and "Node Status".

book

Article ID: 385787

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

In NSX-T 3.2.2.1 there is a condition within the NSX Manager which will cause the "search indexing" mechanism to report "Unknown" for certain Transport Nodes when queried. 

Environment

NSX-T 3.2.2

Cause

This symptom can be caused by a stale Transport Zone issue OR an issue with the "search indexing" mechanisms. 

Resolution

  • Verify that the Transport Zone associated with the affected node is visible using the Elastic Search tool in the NSX GUI. You can also confirm this using the following API call:

                  GET /api/v1/transportzone-profiles?include_system_ownded=true   
              
  • If there are no issues with the Transport Zone configuration, edit the Transport Node in the NSX GUI and click Save without making any changes.

This issue is resolved in NSX version 3.2.3.1.

Additional Information

If the above workaround does not work for you, please collect the below information and open a support request with Broadcom. 

  • NSX Edge and Manager bundles
  • Output for the following API calls:
    GET /api/v1/transportzone-profiles?include_system_owned=true
    GET /api/v1/transport-nodes/
    GET /api/v1/transport-nodes/<tn-uuid>