"Kernel Panic - not syncing: VFS: Unable to mount root fs... " after upgrade of Messaging Gateway
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"Kernel Panic - not syncing: VFS: Unable to mount root fs... " after upgrade of Messaging Gateway

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Article ID: 385747

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Updated On:

Products

Messaging Gateway

Issue/Introduction

After upgrading the Messaging Gateway and rebooting the system, the boot fails with a Kernel Panic similar to the following:

Kernel panic - not syncing: VFS: Unable to mount root fs on unknown block(0,0)

 

Cause

This occurs for appliances that were originally installed with version 10.7.4 or previous and have been upgraded over time. The older appliances have smaller boot partitions that are not large enough for the installations of current appliance updates. Note that this is specifically related to the boot partition and not the general system partitions.

Resolution

If the appliance receives the Kernel Panic, it is not possible to recover directly from that state. If the appliance is on a virtualization platform and a snapshot was taken prior to upgrade, you can revert the snapshot to recover back to the prior version.

To resolve this issue for future upgrade attempts, if you have not encountered the issue yet and are preparing to update an appliance originally installed prior to version 10.7.5 or you can revert the appliance after encountering the issue, you will need to take a full backup of the appliance, and a backup of the Message Audit Logs if wanted. You can also use a full backup that was previously created if you cannot create a new backup.

Reinstall the appliance to the version that matches the backup using an installation .iso image and restore the backup prior to upgrade. The installation from .iso image will correct the boot partition size. Once the appliance is been restored from backup, you will be able to perform the upgrade.

Control Centers hosts 

  1. Download the SMG 10.9.0 ISO from the Broadcom Support portal
  2. Install Messaging Gateway 10.9.0 from ISO into a new virtual machine
  3. Restore the backup taken on 10.9.0 prior to upgrade to 10.9.1 to the new SMG 10.9.0 virtual machine

Scanner only hosts

Scanners do not require backup or restore unless you want to preserve audit log data

  1. Download the SMG 10.9.0 ISO from the Broadcom Support portal
  2. Install Messaging Gateway 10.9.0 from ISO into a new virtual machine
  3. (optional) Back up audit log data from the old 10.9.0 scanner using the command line mallog command
  4. (optional) Restore audit log data to the new 10.9.0 scanner
  5. Delete the old scanner entry from Administration > Configuration in the new Control Center VM
  6. Add the new scanner to the new Control Center via the Administration > Configuration > Add Scanner wizard

Once all SMG virtual machines have been reinstalled and the new scanners have been added to the new Control Center, all SMG system may be safely updated to 10.9.1 by using the command line update install command (10.9.1 upgrade must be done by the command line).

Additional Information