Can't Open lib '/export/home/oracle/product/19.3.0_client32/lib/libsqora.so.19.1' : file not found
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Article ID: 385682
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Updated On:
Products
CA Harvest Software Change ManagerCA Harvest Software Change Manager - OpenMake Meister
Issue/Introduction
When Installing Harvest 14.5, and running HDBSetup, the following error is seen in the main menu
Can't Open lib '/export/home/oracle/product/19.3.0_client32/lib/libsqora.so.19.1' : file not found
Environment
Harvest 14.5 The Unix/Linux platforms
Cause
Three possible causes:
Environment variables do not point to the correct installation
Installation user does not have permissions to access these files
The bit-level for the Oracle Cllient does not match the bit-level for the SCM Server. For example, if SCM Server is a 64-bit application and the Oracle Client is a 32-bit application you will see this type of problem.
Resolution
Ensure the following Environment Variables are configured to supported versions:
export ORACLE_HOME=<folder where Oracle server or client is installed> export ORACLE_SID=<correct Oracle SID for your environment> export PATH=\$ORACLE_HOME/bin:\$PATH export LD_LIBRARY_PATH=\$ORACLE_HOME/lib:$LD_LIBRARY_PATH
Perform the "ls -al " command for the file referenced in the error message. For example
ls -al '/export/home/oracle/product/19.3.0_client32/lib/libsqora.so.19.1'
In the output check the owner and permissions to ensure that the user that owns the Harvest application has at least read permission to the file. For example:
>> ls -al '/export/home/oracle/product/19.3.0_client32/lib/libsqora.so.19.1' >> -rw-r--r-- 1 oracle dba 724256 Jun 3 2019 /export/home/oracle/product/19.3.0_client32/lib/libsqora.so.19.1
Note the Bold section of the error: Can't Open lib '/export/home/oracle/product/19.3.0_client32/lib/libsqora.so.19.1' : file not found This is asking for the 32 bit client, yet 14.5 of Harvest does not support 32 Bit client in Linux. Ensure the bit versions match
To install the 64-bit Oracle client or InstantClient and reconfigure Harvest to use it:
Install the 64-bit Oracle Client to a new folder
Update .bash_profile of the cascm user to reference the new ORACLE_HOME folder
Re-source the profile by exiting the cascm user and logging back in
Re-install the odbc module from the odbc.tar.gz package that was included with your version of Harvest.
Navigate to $CA_SCM_HOME/install and execute the install.sh script. Select option 3 to "Change CA Harvest SCM installation configuration" and complete the wizard, confirming all settings are correct.
After that, restart the broker and retest to ensure the error no longer appears.