Problems with dates newer than 2038 - Y2K38 Issue
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Problems with dates newer than 2038 - Y2K38 Issue

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Article ID: 385676

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

In date fields SDM cannot handle dates greater than 2038-01-20.  Users cannot select a date past Jan 18, 2038.

Environment

Release : 17.3 (All RU's) and 17.4 RU3
CA Service Desk Manager

Cause

This is the limitation of representing the date using unsigned int. 

Resolution

Unfortunately, this is the limitation of representing the date using unsigned int. Currently, the Service Desk Manager application does not support this.

The Year 2038 problem (also called Y2038, Epochalypse[1][2], Y2k38, or Unix Y2K) relates to representing time in many digital systems as the number of seconds passed since 00:00:00 UTC on 1 January 1970 and storing it as a signed 32-bit integer. Such implementations cannot encode times after 03:14:07 UTC on 19 January 2038. Similar to the Y2K problem, the Year 2038 problem is caused by insufficient capacity used to represent time.

Currently, the ServiceDesk Manager application is not supporting this. This requires a good amount of changes and needs to be handled as an enhancement.