Unable to upload a patch file to vCenter Lifecycle Manager Baseline
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Unable to upload a patch file to vCenter Lifecycle Manager Baseline

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Article ID: 385664

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

Trying to upload a file to vCenter Life Cycle Manager baseline or import an update to an existing baseline result in one of the following UI errors

General system error occurred: A depot is inaccessible or has invalid contents. Make sure an official depot source is used and verify connection to the depot

A general system error occurred: File name/URL of the depot is not valid or cannot be reached now.


Logs from vCenter /var/log/vmware/vmware-updatemgr/vum-server/imageservice.log

ERROR imageService[<UUID>] [imageService 628] Failed to validate depot: ('zip:/storage/updatemgr/patch-store-temp/vum<FILENAME>.zip?index.xml', '', 'Could not download from depot at zip:/storage/updatemgr/patch-store-temp/vum<FILENAME>.zip?index.xml, skipping ((\'zip:/storage/updatemgr/patch-store-temp/vum<FILENAME>.zip?index.xml\', \'\', \'Error extracting index.xml from /storage/updatemgr/patch-store-temp/vum<FILENAME>.zip: "There is no item named \\\'index.xml\\\' in the archive"\'))')

Cause

The offline depot file being used is either corrupt or not an offline bundle file which is indicated in the logs by the missing index.xml file which is expected in the offline.zip file. This can also occur if the zip file being uploaded to LCM is a wrapper archive with the offline bundle inside the archive.

Resolution

  • Ensure the correct offline log bundle is being used and the provided checksum matches the downloaded file.
  • Extract the zip file(s) to ensure the archive being uploaded to LCM contains the index.xml file.

Additional Information