Diagnostics for VMware Cloud Foundation - Certificates “No data available”
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Diagnostics for VMware Cloud Foundation - Certificates “No data available”

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Article ID: 385654

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Updated On:

Products

VMware Aria Suite

Issue/Introduction

The Certificates dashboard is reporting “No data available” under the Diagnostics Management pack. This dashboard obtains its data from VMware Infrastructure Health (VIH) management pack.

Also the Certificate and License details may be missing under Inventory - Integrations - VMware Infrastructure Health.

This image shows a working cluster on the left with the expected details and on the right a cluster where the details are missing.

 

It has also been observed that there are “No License Available” under Subscriptions → License Management. 

Environment

VMware Cloud Foundation 5.2

VMware Aria Suite 8.18.0 to 8.18.2

Cause

This is caused by an NPE exception in VMware Infrastructure Health (VIH) management pack. 

 

Log snippet from the VIH log:

com.vmware.adapter3.vmwareinfrahealth.VMwareInfraHealthAdapter.onCollect - Unable to collect data, exception caused is:

VMwareInfraHealthAdapter_16095.log.1| java.lang.NullPointerException: null

VMwareInfraHealthAdapter_16095.log.1| at          com.vmware.adapter3.vmwareinfrahealth.VMwareInfraHealthAdapter.updateAdapterInstance(VMwareInfraHealthAdapter.java:1351) ~[VMwareInfrastructureHealthAdapter.jar:?]

 

To check the VIH log please go to:

Operations UI

Administrator --> Control Panel --> Support Logs --> Collector --> adapters --> VMwareInfraHealthAdapter

CLI

/storage/log/vcops/log/adapters/VMwareInfraHealthAdapter

Resolution

This issue is the VMware Infrastructure Health (VIH) management pack found in Operations 8.18.3.