maileater does not create tickets
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maileater does not create tickets

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Article ID: 385532

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Maileater can connect to the mailbox, and reads the emails but fails to create the SDM ticket(s) with the following error in NX_ROOT/log/stdlog:

ERROR        top_ob.c              4032 Got msg with type set to 0
ERROR        text_api.spl          2393 fetch_dob_list userid (<userID>) in factory (agt) not found
ERROR        text_api.spl          2393 fetch_dob_list last_name (<GroupName>) in factory (grp) not found
ERROR        top_ob.c              4032 Got msg with type set to 0
ERROR        cr_chg_text_api.spl   1420 We were unable to process your request at this time.

Environment

SDM 17.x

Cause

Permission issue in the Access Type being used

Resolution

Change the Command Line Utility Role for the failing users with the steps below:

1. Identify the users who are experiencing the issue and identify the Access type: Administration > Security and Role Management > Contacts > Click on Contact and note the Access Type

2. Go to the Access Type: Administration > Security and Role Management > Access Types > Click on the Access Type from the contact above

3. Go to 3. Roles tab > Click on Edit 

4. Edit the Command Line Utility Role and set a Role with permissions to create tickets.

5. Save Changes