Error: "Invalid hard disk parameters specified" while detaching the named disk
search cancel

Error: "Invalid hard disk parameters specified" while detaching the named disk

book

Article ID: 385523

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

Unable to detach the named disk in VMware Cloud Director.

Error:

Invalid hard disk parameters specified. The following parameters are invalid or conflict with other configured devices in the virtual machine: [vcId=87ae####-####-####-####-######2faa, moref=vm-1244607] Adapter Type: NVME, Bus Number: 0, Unit Number: 0

Log:

ERROR    | task-service-activity-pool-45 | FutureUtil | Error detaching disk datadisk-10(com.vmware.vcloud.entity.disk:d5e7#####-#####-#####-#####-#####3592) from VM 10-DIECI(com.vmware.vcloud.entity.vm:1270960f-f7c1-40b4-938a-c92096f9a1e8) | requestId=6a1c#####-#####-#####-#####-#####20fdd,request=POST <vcd url>/api/vApp/vm-127####-#####-#####-#####-##########a1e8/disk/action/detach,requestTime=1727##########,remoteAddress=##.##.#.#:####00,userAgent=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 ...,accept=application/*+json;version 39.0.0-alpha vcd=c9fe#####-#####-#####-#####-##########c300,task=3ff6#####-#####-#####-#####-#####e67a activity=(com.vmware.vcloud.backendbase.management.system.TaskActivity,urn:uuid:3ff6#####-#####-#####-#####-#####e67a)
com.vmware.vcloud.api.presentation.service.BadRequestException: Invalid hard disk parameters specified. The following parameters are invalid or conflict with other configured devices in the virtual machine: [vcId=87ae#####-#####-#####-#####-#####2faa, moref=vm-######] Adapter Type: NVME, Bus Number: #, Unit Number: #

 

Environment

VMware Cloud Director 10.5.x

Cause

This issue occurs when there is a mismatch between the vmdk file name from vCenter mob view and VCD Database.

Resolution

To resolve this issue, contact Broadcom Support and note this Article ID (385523) in the problem description. For more information, see Creating and managing Broadcom support cases