SiteMinder policy server: Misses Per Interval increases
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SiteMinder policy server: Misses Per Interval increases

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Article ID: 385492

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Updated On:

Products

CA Single Sign On Agents (SiteMinder) SITEMINDER

Issue/Introduction

During overnight testing that occurs every night, and wily metrics showed a traffic divergency.

It was observed that in APM monitory graph "Authorization Cache Misses" appears to almost doubled in numbers as everything else has stayed consistent. 

Environment

SiteMinder: ALL

Cause

Load test data itself or environment related cause.

Resolution

This is NOT a SiteMinder product problem.

From APM documentation.

  • Hits Per Interval: Number of hits per interval for a particular resource in Policy Server
  • Misses Per Interval: Number of misses per interval for a particular resource in the Policy Server is a result of unsuccessful cache lookups.

Misses Per Interval: Number of misses per interval for a particular user resource in the Policy Server is a result of unsuccessful user cache lookups.

The cache referred to is Policy Server user authorization cache.

Is this caching from the agent or the policy server?
Answer: APM graph "Misses Per Interval" is Authorization Cache Miss matrix at policy server. Basically this cache refers to the policy resolution lookup cache during user authorization.

Is there an agent configuration object parameter that needs to be activated?
Answer: No.

Is there anyway to tune the cache?
Answer: Yes, by changing DSInfo cahce size in policy server registry.
DsInfoMaxSizeMB in sm.regsitry can be set at higher value. Default is 10 MB.

What is the symptom of this divergence?
Answer: It could be lot of different users logging in after a long test duration.

Is there anyways to log these miss hits? how does one find that?
Answer: Out of box, this is NOT possible from logging. Only Instrumented code could show it, but that is not something a production setup would commonly need or want.
"Misses Per Interval" is actually a counter defined in SM_DSINFO_STATS m_nTtlMissCount++; the counter result is stored in memory and ready to be retrieved by APM agent, but not from logging code.

Is there configurations can be done to smtracedefault.txt or anything that needs to be enabled in order to see these in the logs?
Answer: refer to the answer above.

Additional Information