The "update check" or "update download" commands fail with "Error: Invalid version flag: if"
search cancel

The "update check" or "update download" commands fail with "Error: Invalid version flag: if"

book

Article ID: 385400

calendar_today

Updated On: 03-25-2025

Products

Messaging Gateway Messaging Gateway for Service Providers

Issue/Introduction

You are trying to upgrade the Messaging Gateway to 10.9.1 and have run the command "update check" or "update download" as part of the process. The command ends with the error "Error: Invalid version flag: if" and does not complete successfully.

Environment

10.9.1

Cause

This is a known issue documented in the Release Notes:

Due to the nature of this release, and the upgrade of the underlying operating system, update download and update
check commands cannot work properly for the 10.9.1 release.

To update Messaging Gateway 10.9.0 to 10.9.1 from the command line, use the update install command which will both download and install the SMG operating system update.

As always, it is recommended that Messaging Gateway software update best practices be observed when updating to a new release.

 

Resolution

To resolve this issue, do not use the "update check" or "update download" commands. Fully read the Release Notes and follow the Best practices for all updates list.

Additional Information

In addition to not running the referenced commands, 10.9.1 also includes these caveats to be especially aware of:

ATTENTION
Do not update the Control Center from the SMG UI. The Control Center must be updated from the
Command Line Interface. Once the Control Center is updated, you can use the SMG UI to update other
quarantines or scanners.

IMPORTANT
Once the upgrade has begun and the first portion is installed, it must run to a successful installation of SMG
10.9.1. If the upgrade fails mid-process, or is interrupted, then the system will be in an unstable state, and
cannot be recovered. It must be re-installed and re-configured. If you wish to retain your configuration, you must
make a full backup before beginning the upgrade process.

The Release Notes and other related documents can be obtained from the following URL:

https://techdocs.broadcom.com/us/en/symantec-security-software/email-security/messaging-gateway/10-9-1/related-documents.html