Update check or download fails with Error: Invalid version flag: if - Messaging Gateway
search cancel

Update check or download fails with Error: Invalid version flag: if - Messaging Gateway

book

Article ID: 385400

calendar_today

Updated On:

Products

Messaging Gateway Messaging Gateway for Service Providers

Issue/Introduction

Messaging Gateway 10.9.0 to 10.9.1 upgrades fail when using update check or update download commands. This results in the error Error: Invalid version flag: if and prevents successful updates via the Command Line Interface (CLI) or the Control Center UI. 

Environment

  • Product: Symantec Messaging Gateway (SMG)
  • Version: 10.9.0-3 upgrading to 10.9.1-3
  • Deployment: Virtual (VMware) and Hardware Appliances

Cause

Architecture changes to the underlying operating system in release 10.9.1 prevent the update download and update check commands from functioning properly. These commands are incompatible with the 10.9.1 upgrade path.

 

Resolution

Fixed in release 10.9.1 and higher. See Download Broadcom products and software for steps to download this release.

To resolve this issue, use the update install command from the CLI. This command bypasses the separate check/download phases and performs both the download and the SMG operating system update in one process.

Upgrade Constraints and Best Practices

  • Control Center Update: Do not update the Control Center from the SMG UI. The Control Center must be updated via the CLI. Once the Control Center is updated, the SMG UI can be used to update other scanners.
  • Installation Continuity: Once the upgrade begins and the first portion installs, it must run to completion. If the process is interrupted or fails mid-process, the system may enter an unstable state requiring a full re-installation.
  • Backups: Perform a full backup before beginning the upgrade process to retain configurations.
  • Related Documentation: Review the Symantec Messaging Gateway 10.9.1 Related Documents and Messaging Gateway software update best practices.

Additional Information

In addition to not running the referenced commands, 10.9.1 also includes these caveats to be especially aware of:

ATTENTION
Do not update the Control Center from the SMG UI. The Control Center must be updated from the
Command Line Interface. Once the Control Center is updated, you can use the SMG UI to update other
quarantines or scanners.

IMPORTANT
Once the upgrade has begun and the first portion is installed, it must run to a successful installation of SMG
10.9.1. If the upgrade fails mid-process, or is interrupted, then the system will be in an unstable state, and
cannot be recovered. It must be re-installed and re-configured. If you wish to retain your configuration, you must
make a full backup before beginning the upgrade process.

The Release Notes and other related documents can be obtained from the following URL:

Symantec Messaging Gateway 10.9.1 Related Documents