Error: "Connection refused (Connection refused)" for "api/admin/extension/settings/amqp/action/test" requests every 5 minutes in Cloud Director logs after removing AMQP host details using VCD API
search cancel

Error: "Connection refused (Connection refused)" for "api/admin/extension/settings/amqp/action/test" requests every 5 minutes in Cloud Director logs after removing AMQP host details using VCD API

book

Article ID: 385362

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • The /opt/vmware/vcloud-director/logs/vcloud-container-debug.log files on the Cloud Director Cells show repeated warnings of the form:

<timestamp> | WARN     | pool-jetty-###        | SystemServiceImpl              | Unsuccessful AMQP connection test, settings: [host=, port=5672, username=<username>, exchange=systemExchange, vHost=/, useSSL=false, prefix=vcd] | requestId=########-####-####-####-############-########-####-####-####-############,request=POST https://<vcd_public_address>/api/admin/extension/settings/amqp/action/test,requestTime=<request_time>,remoteAddress=<remote_address>:<remote_port>,userAgent=vcd-client,accept=application/*+xml;version <vcd_api_version>
java.net.ConnectException: Connection refused (Connection refused)

  • The /opt/vmware/vcloud-director/logs/<date>.request.log files on the Cloud Director Cells show repeated API calls to Cloud Director to test the AMQP settings of the form:

<remote_address> - - [<timestamp>] "POST /api/admin/extension/settings/amqp/action/test HTTP/1.1" 200 1326 "-" "vcd-client" 18

  • AMQP is no longer used or required by the Cloud Director instance.

Environment

VMware Cloud Director 10.x

Cause

Cloud Director will accept API requests, "POST /api/admin/extension/settings/amqp/action/test", to test the AMQP settings even when no AMQP host is configured or the AMQP host has been removed as per the process in the KB article, Remove AMQP Broker Settings from VMware Cloud Director.

If the AMQP host is empty then the test will always fail with the warning in the logs as there is no reachable AMQP host:

Unsuccessful AMQP connection test, settings: [host=,

Resolution

To stop Cloud Director logging the warnings, stop the external client from making repeated requests to the Cloud Director API, "POST /api/admin/extension/settings/amqp/action/test".

If the external client can not be identified it may be possible to stop the warnings by removing the AMQP password from the AMQP settings in the Cloud Director database.
For assistance with this step please contact Broadcom Support and note this Article ID (385362) in the problem description. For more information, see Creating and managing Broadcom support cases.

Additional Information