Error 'Internal Server Error - Row was updated or deleted by another transaction' when powering on virtual machines in the VMware Cloud Director tenant portal
search cancel

Error 'Internal Server Error - Row was updated or deleted by another transaction' when powering on virtual machines in the VMware Cloud Director tenant portal

book

Article ID: 385325

calendar_today

Updated On:

Products

VMware Cloud Director

Issue/Introduction

After upgrading VMware Cloud Director to version 10.6.0.1, the following behavior is observed:

  • Existing powered-on VMs can be powered off and then powered back on without issue.
  • Existing powered-off VMs fail to power on.
  • Newly created VM cannot be powered on
  • The following error is logged in the /opt/vmware/vcloud-director/logs/vcloud-container-debug.log file when the VM power-on task fails:

Internal Server Error - Row was updated or deleted by another transaction (or unsaved-value mapping was incorrect): [com.vmware.vcloud.fabric.compute.model.VRPModel########-####-####-#########]

Environment

VMware Cloud Director 10.6.0.1

Cause

The operation fails due to a StaleObjectStateException when attempting to add the missing resource pool during the VM power-on process.

This is a known issue affecting VMware Cloud Director version 10.6.0.1.

Resolution

This issue has been fixed in VMware Cloud Director version 10.6.1 version that can be downloaded on Broadcom Download Portal

Workaround:

1) Log in to the VMware Cloud Director Provider portal.

2) Navigate to Organization VDCs under Resources.

3) Select the VDC where the VMs are failing to power on.

4) In the left panel, click Allocation and then select Edit.

5) Choose one of the following options:

    • Update the Organization VDC limit so that it is below the actual capacity of the Provider VDC (Cluster/Resource Pool at the vCenter level)
    • Set the limit to Unlimited.

6) Save the changes.

7) Once the settings are updated, go to the VMware Cloud Director tenant portal and try powering on the VM again.