VCF Operations or Aria Operations for Logs upgrade fails at Stage 3 with Error LCMCOMMON80001
search cancel

VCF Operations or Aria Operations for Logs upgrade fails at Stage 3 with Error LCMCOMMON80001

book

Article ID: 385245

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

  • The upgrade of  Aria Operations for Logs/ Aria Operations fails at stage 3 in Aria Suite Lifecycle

Error Code: LCMCOMMON80001
Generic system error
Failed to find a VA with ip '<Node-FQDN>', hostname : '<Node-FQDN>'

  • Applying the patch on VCF Operations / VCF Operation for Logs via VCF Fleet Management  fails with Error Code: LCMCOMMON80001
  • The following entry is seen in the /var/log/vrlcm/vmware-vrlcm.log file:
INFO vrlcm[1219] [pool-3-thread-98] [c.v.v.l.d.v.v.u.CoreUtility]  -- VM search MorefId :vm-ID
INFO vrlcm[1219] [pool-3-thread-98] [c.v.v.l.d.v.v.u.CoreUtility]  -- VM Name  : node-### 
INFO vrlcm[1219] [pool-3-thread-98] [c.v.v.l.d.v.v.u.CoreUtility]  -- NOT FOUND :: VA with name : node-### & IP : <IP-ADDRESS>& Hostname : <Node-FQDN> . Retry count : 6. Sleeping for : 20 seconds

Environment

Aria Suite Lifecycle 8.18.x
VCF Fleet Management 9.x
VCF Operations 9.x

Cause

The issue was caused by incorrect DNS configurations in the vCenter vApp options for the affected nodes.

Resolution

Perform the below steps to resolve the DNS mismatch and resume the upgrade/patching process:

Aria Operations for Logs 

VCF Operations

  • Ensure the VCF Operations nodes are correctly configured with the proper DNS settings in the vCenter vApp options (navigate to Configure > Settings > vApp Settings).
  • Incase the vApp option is disable, please follow Activate vApp Options for a Virtual Machine

After correcting the DNS configuration, Re-try the upgrade or patch request from Aria Suite Lifecycle or VCF Fleet Management.