'user not authorized' message when accessing MODE JOB - Job Selection List screen
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'user not authorized' message when accessing MODE JOB - Job Selection List screen

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Article ID: 385158

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Updated On:

Products

View

Issue/Introduction

When trying to access JOB mode via a MODE JOB command on the primary options screen, I receive an authorization failure message such as:

- User not authorized

- Unauthorized command

- Userid is not authorized to access requested mode

View is configured with SARINIT parameter SECURITY=EXTERNAL.

Environment

z/OS, View, MODE, JOB, COMMAND, user, userid, not, authorized, external, security, internal, authorization, failure

Cause

Insufficient access.

Resolution

A. On the DEF USER screen in View, when a logon ID is configured with an 'N' in the JOB MODE field of the AEESSJ column: 

 CA View ALL -------------- Userid Definition Panel ------
 Command ===>                                             
                      --- Last Access ---      AEESSJ     
Sel Userid   Password Date       Time     M L   O O   Mode
    probuid           12/30/2024 09:17:40 Y RW YNNNNN ALL


They receive the following error when they attempt to change from 'MODE ALL' to 'MODE JOB':

ENTER gets: Unauthorized command - PF1 shows: Userid is not authorized to access requested mode 

 


B. When I change my logon ID and configured it with a 'Y' in the JOB MODE field of the AEESSJ column:

 CA View JOB -------------- Userid Definition Panel ------
 Command ===>                                             
                      --- Last Access ---      AEESSJ     
Sel Userid   Password Date       Time     M L   O O   Mode
    probuid           12/30/2024 09:17:40 Y RW YNNNNY JOB


I am able to successfully change from 'MODE ALL' to 'MODE JOB'.


C. Considering the above, please access the DEF USER screen for the userid who is having the problem and configured them with a 'Y' in the JOB MODE field of the AEESSJ column. Then have that user logoff of View and then back on, and see if they can change to MODE JOB.

D. If they are still receiving an error, press the PF1 key and send support a screen print showing them specifically what error the user is receiving on their screen.

E. Determine what protocol the problem user is using to sign on to View (i.e. Are they logging on through a TSO/ISPF clist? through CICS? through VTAM? etc...) so that when security debugging is turned on via SARINIT FEATURE=1,  you will know where to look for the security call and failure messages that will be issued if the user is denied access to MODE JOB - Job Selection List screen again.

- If signon is through a CLIST, then look in the users TSO LOGON profile.

- If signon is through a protocol that involves the XMS task, then the security call & failure messages can be found in the XMS task logs.