CSV Export notification: Download by NaN NaN
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CSV Export notification: Download by NaN NaN

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Article ID: 385085

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

When exporting to CSV any Clarity MUX grid, the CSV Export notification does not show the Download By Dates correctly, it shows Download by NaN NaN instead. 

This happens to all users irrespective of the user language and locale settings. 

When looking at the browser developer tools api call response when opening the notifications bell icon, we can see the following response and the dates being set to Finnish

{
    "_pageSize": 9,
    "_self": "http://myClarityserver/ppm/rest/v1/private/pullNotifications?limit=9&offset=0",
    "_totalCount": 1,
    "_results": [
        {
            "isVisited": 0,
            "details": {
                "jobStatus": "COMPLETED"
            },
            "id": "5085011",
            "notificationType": "csv_export",
            "message": "{\"downloadByDate\":\"tammikuuta 07, 2025\",\"fileName\":\"Unsaved_5912088.csv\",\"downloadLink\":\"http://myClarityserver/ppm/rest/v1/virtual/attachments/eyJyZXNvdXJjZUlkIjoiMSIsInZlcnNpb25JZCI6NTEwMDkxMCwicmVzb3VyY2VOYW1lIjoiY3N2RXhwb3J0IiwiZmlsZUlkIjo1MTAwOTA5fQ\",\"object\":\"Time Inv\"}"
        }
    ],
    "_recordsReturned": 1
}

On an environment where the notification shows correct dates, the response looks like below:

{
    "_pageSize": 9,
    "_self": "http://myClarityserver/ppm/rest/v1/private/pullNotifications?limit=9&offset=0",
    "_totalCount": 1,
    "_results": [
        {
            "isVisited": 0,
            "details": {
                "jobStatus": "COMPLETED"
            },
            "id": "5085011",
            "notificationType": "csv_export",
            "message": "{\"downloadByDate\":\"Jan 07, 2025\",\"fileName\":\"Unsaved_5912088.csv\",\"downloadLink\":\"http://myClarityserver/ppm/rest/v1/virtual/attachments/eyJyZXNvdXJjZUlkIjoiMSIsInZlcnNpb25JZCI6NTEwMDkxMCwicmVzb3VyY2VOYW1lIjoiY3N2RXhwb3J0IiwiZmlsZUlkIjo1MTAwOTA5fQ\",\"object\":\"Time Inv\"}"
        }
    ],
    "_recordsReturned": 1
}

 

Environment

Any Clarity release

Cause

The java locale is set to a non US English locale

Resolution

Set Java Locale

  1. Edit your properties.xml or CSA
  2. For App and BG service JVM settings, add the below parameters at the end of the line and save:
    -Duser.country=US -Duser.language=en 
    Example:
  3. Restart services