Unable to expand the VMDK with: "A general system error occurred: PBM error occurred during PreReconfigureCallback: Fault cause: vmodl.fault.SystemError"
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Unable to expand the VMDK with: "A general system error occurred: PBM error occurred during PreReconfigureCallback: Fault cause: vmodl.fault.SystemError"

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Article ID: 385084

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Updated On:

Products

VMware vCenter Server VMware vCenter Server 7.0

Issue/Introduction

Symptoms: 

  • Unable to expand a hard disk in vCenter.
  • Attempting to Increase the space for a hard disk fails with the error: 'A general system error occurred: PBM error occurred during PreReconfigureCallback: Fault cause: vmodl.fault.SystemError.
  • In the /var/log/vmware/vmware-sps/sps.log

vmname -- vm-id -- vim.VirtualMachine.reconfigure: vmodl.fault.SystemError:
-- > Result:
-- > (vmodl. fault.SystemError) {
faultCause = (vmodl.MethodFault) null,
faultMessage = <unset>,
reason = " PBM error occurred during PreReconfigureCallback: Fault cause: vmodl. fault.SystemError

-- >

-- >

msg = ""

java.util.concurrent.ExecutionException: (pbm.fault.PBMFault) {
faultCause = null,
faultMessage = (vmodl. LocalizableMessage) [
(vmodl.LocalizableMessage) {
dynamicType = null,
dynamicProperty = null,
key = com.vmware.pbm.pbmFault.locale,
arg = (vmodl.KeyAnyValue) [
(vmodl.KeyAnyValue) {
dynamicType = null,
dynamicProperty = null,
key = summary,
value = No VASA Provider for schema namespace (VSAN) found.

1,
message = null

YYYY-MM-DDThh:mm:ss.821Z [pool-30-thread-3] WARN opId=########-####-####-####-############ com.vmware.vim. sms.provider.vasa. VasaProviderInfoPersistence

Manager - [cleanProvider] Failed to remove provider from KV store!
com.vmware.vim.sms.fault.DBPersistenceException: Exception occured when removing the provider information in KV store########-####-####-####-############

Environment

VMware vCenter Server Appliance 7.x

Cause

This issue occurs when the database contains stale entries, which prevents the vSAN VASA Provider (VSANVP) from successfully registering. 

Resolution

Please contact Broadcom support for assistance with the resolution.