vSphere HA Agent Connectivity Issues: 'Cannot Reach Management Network Addresses' on ESXi Hosts
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vSphere HA Agent Connectivity Issues: 'Cannot Reach Management Network Addresses' on ESXi Hosts

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Article ID: 385031

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Updated On:

Products

VMware vCenter Server 7.0 VMware vCenter Server 8.0 VMware vSphere ESXi 7.0 VMware vSphere ESXi 8.0

Issue/Introduction

The impacted host displays the alert: "vSphere HA agent on host cannot reach some management network addresses of other hosts."

Environment

VMware ESXi 7.x

VMware ESXi 8.x

Cause

This issue occurs when a host experiencing a vSphere HA event is unable to ping or reach the Management Network IP address of other hosts in the cluster. The cause could be firewall rules, an incorrect Management Network IP, use of IPv6, or other network connectivity issues.

These alerts are triggered when a host goes down due to various reasons, including changes in the Master Host. If this impacts vSphere HA, it will automatically be reconfigured at the host level for the affected host to restore functionality.

Resolution

To Resolve vSphere HA Agent Connectivity Issues:

  • Disable and Re-enable vSphere HA
    • Log in to vCenter Server.
    • Right-click the cluster and select Settings.
    • Under Services, click on vSphere Availability.
    • In vSphere Availability, click Edit for vSphere HA, toggle to disable vSphere HA, and click OK.
    • To re-enable vSphere HA, click on Edit vSphere HA, toggle to enable, and click OK. Wait for all hosts in the cluster to be reconfigured with vSphere HA.

In some cases, alternatively, restarting the vSphere HA agent on the ESXi host might resolve the issue:

  • Select the impacted ESXi Host.
  • Navigate to the Configure tab.
  • Under Services and System, select vSphere High Availability Agent and click Restart at the top, then click OK. Wait for the service to restart and complete. This can be confirmed in the Recent Tasks panel.

In case the issue persists, restart the ESXi hostd and vpxa services:

  • Log in to ESXi Shell or SSH as root.
  • Run the following commands:
    • # /etc/init.d/hostd restart
    • # /etc/init.d/vpxa restart