Ping attempts from the Windows VM resulted in a 'General Failure' error when a security software agent is installed in the guest Operating System.
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Ping attempts from the Windows VM resulted in a 'General Failure' error when a security software agent is installed in the guest Operating System.

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Article ID: 384947

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Updated On:

Products

VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

  • The Windows virtual machine is experiencing network connectivity issue.
  • VM guest is booted up, but lost Network connectivity. when trying to ping gateway, getting "general failure"
  • The VM failed to establish ICMP echo requests to both the default gateway and other virtual machines residing within the same subnet with the 'General Failure' error.
  • Packet capture analysis revealed an absence of transmitted packets (tx) on the virtual network interface card (vNIC) of the virtual machine.
  • Packet loss was observed prior to reaching the virtual network interface card (vNIC), indicating that packet drops occurred within the guest operating system.
  • Guest OS has cyber security software, for example CrowdStrike Falcon agent, is installed and running.
  • Booting the Windows Operating System into Safe mode allows the network packets to be successfully sent. 

Cause

The Cyber Security software agent acts as a sensor, constantly monitoring the endpoint for any signs of compromise and providing real-time protection against cyber threats. Network services may be blocked by a Cyber Security software which may have identified any threats inside the guest OS. 

Resolution

As the Cyber Security software has disabled network services in the guest OS, please investigate with the cyber security software vendor to understand and mitigate the cause.

Workaround

  • Removal of the cyber security software will result in the restoration of network functionality for the guest Operating System.