Web Agent logs are not rotating
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Web Agent logs are not rotating

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Article ID: 384946

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Updated On:

Products

SITEMINDER CA Single Sign On Agents (SiteMinder) CA Single Sign On Federation (SiteMinder) CA Single Sign On Secure Proxy Server (SiteMinder)

Issue/Introduction

The Web Agent is configured to rotate its logs based on size, but the logs are continuing to grow long after exceeding the configured maximum size.   Log rotation is also referred to as rollover or archiving.

Environment

All Supported Releases, all Platforms

Cause

When LogAppend=yes in the Agent Configuration Object (ACO), no log rotation will occur.  

Resolution

Set LogAppend=no and verify that LogFileSize is set.  

Additional Information

This information applies to both the Web Agent error log as well as the Web Agent trace log.  The Log* ACO parameters control error logging while the Trace* ACO parameters control trace logging.